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Important Power Information
To avoid damage to the CL-GigE (and in some cases the connected equipment), it is important that you 
follow the correct power sequence:

• If you are using GPIO inputs, set the Differential Type switch and I/O Level switch BEFORE you 
connect equipment and BEFORE you apply power to the CL-GigE.

• Always power up the CL-GigE BEFORE the camera:

• Power up the CL-GigE and wait until it is fully powered (the Power/FPGA status LED is 
green). 

• Connect the camera to the CL-GigE. 

• Apply power to the camera.

• Always power down the camera BEFORE you power down the CL-GigE.

Complete Power Information and Instructions

For complete power information and instructions, refer to the following sections of this guide:

Important Overview: “Powering the CL-GigE” on page 23

• “Differential Type and I/O Level Switches” on page 19

• “Powering the CL-GigE Using PoE” on page 23

• “Powering the CL-GigE Using an External Power Supply” on page 24





Ensuring Proper Image Streaming 
From a Camera Link Camera

Important: Before you attempt to stream images, you must know the image settings of your Camera Link 
camera, and then configure the CL-GigE with matching image settings.

Steps to Ensure Proper Image Streaming

1. Ensure you have installed the latest release of Pleora’s eBUS SDK and supporting drivers on your
computer. For more information, see “Installing the eBUS SDK” on page 41.

2. Physically connect the camera, CL-GigE, and computer. Power up the system. For more
information, see “CL-GigE Connections” on page 11.

3. Test the connection between the CL-GigE and the computer using the test pattern. For more
information, see “Confirming Image Streaming” on page 50.

4. If you want to configure your camera’s settings or if your camera requires that you send a serial
command to start image acquisition, you can set up Camera Link serial communications. For more
information, see “Accessing your Camera Settings through Camera Link Serial Communications”
on page 54.

5. After you have configured the image settings on the camera, you must then configure matching
image settings on the CL-GigE. For more information about configuring CL-GigE settings, see
“Configuring CL-GigE Image Settings Using eBUS Player” on page 55.

The changes that you make to your CL-GigE are temporary and WILL NOT PERSIST ACROSS POWER CYCLES. 
Save your settings using the steps outlined in “Saving eBUS Player and CL-GigE Settings” on page 67 to 
avoid losing changes when the CL-GigE is power-cycled.
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Chapter 1

About this Guide
This chapter describes the purpose and scope of this guide, and provides a list of complementary guides.

The following topics are covered in this chapter:

• “What this Guide Provides” on page 2

• “Documented Product Versions” on page 2

• “Related Documents” on page 3

• “Further Reading” on page 3
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What this Guide Provides

This guide provides you with the information you need to connect the CL-GigE to a Base Camera Link 
camera.

In this guide you can find product overviews, instructions for connecting the cables, installing the Pleora 
eBUS™ SDK, establishing connections, performing general configuration tasks, and configuring the 
settings to properly capture and display images from a Camera Link camera. The last chapter of this guide 
provides Technical Support contact information for Pleora Technologies.

Documented Product Versions

This guide covers the following product versions. The features and functionality documented in this 
guide may vary if you are using an earlier or later version of the product.

Table 1: Documented Product Versions

Product Release/version documented in this guide...

iPORT CL-GigE External Frame Grabber 1.3.2

eBUS SDK and eBUS Player 6.1
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Related Documents

The iPORT CL-GigE External Frame Grabber User Guide is complemented by the following Pleora 
Technologies documents, which are available on the Pleora Technologies Support Center 
(supportcenter.pleora.com):

• eBUS Player Quick Start Guide and eBUS Player User Guide, available for Windows, Linux, and 
macOS

• eBUS SDK API Quick Start Guides, available for C++, .NET, Linux, and macOS

• iPORT Advanced Features User Guide

• Configuring Your Computer and Network Adapters for Best Performance knowledge base article

• Stream Control Application Note

• Introduction: Establishing a Serial Bridge knowledge base article

• Updating Pleora Firmware knowledge base article

You can also consult the eBUS SDK API Help Files, which are installed on your computer during the 
installation of the eBUS SDK. You can access this documentation from the Windows Start menu under 
eBUS SDK.

Further Reading

Although not required in order to successfully use the CL-GigE, you can find details about industry-
related standards and naming conventions in the following documents:

• GigE Vision Standard, version 2.0 available from the Automated Imaging Association (AIA) at 
www.visiononline.org.

• GenICam Standard Features Naming Convention available from the European Machine Vision 
Association (EMVA) at www.emva.org.

• Camera Link Standard, version 2.0 available from the Automated Imaging Association (AIA) at 
www.visiononline.org.

• Pixel Format Naming Convention, available from the European Machine Vision Association 
(EMVA) at www.emva.org.
3About this Guide

http://www.emva.org
http://www.visiononline.org
https://supportcenter.pleora.com/s/
http://www.emva.org
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Chapter 2

About the iPORT CL-GigE External Frame Grabber
This chapter describes the CL-GigE External Frame Grabber, including the models and key features.

The following topics are covered in this chapter:

• “Models” on page 6

• “Feature Set” on page 7

• “Key GenICam Features” on page 8

• “Available Pixel Formats” on page 9
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Models

The CL-GigE is available in several models and is equipped with the parts listed in the following tables. 
Before assembly, ensure that all components are included in the selected package.

* We recommend that you use a PoE power injector, PoE-enabled GigE switch, or an external power supply such 
as the one supplied by Pleora, part number 904-3905.

** If you will be powering the CL-GigE using PoE and do not plan on using the CL-GigE’s GPIO signals, you do 
not need to solder the 12-pin GPIO connector to the board.

Table 2: Models

Order code Model Quantity

900-6010 iPORT CL-GigEB-IND in mountable enclosure

Device Model Name: iPORT CL-GigE-PT01-CL0IP01-128x

iPORT CL-GigEB-IND External Frame Grabber in mountable enclosure for 
Camera Link Base mode (industrial use).*

1

900-6009 iPORT CL-GigEB-IND OEM board set

Device Model Name: iPORT CL-GigE-PT01-CL0IP01-128x

iPORT CL-GigEB-IND External Frame Grabber OEM board set for Camera Link 
Base mode (industrial use).*

• Includes a GPIO board assembly, flat flex cable, unsoldered 12-pin GPIO 
connector, and SDR-26 jack socket screws**

1

900-6011 iPORT CL-GigEB-IND Development Kit

iPORT CL-GigEB-IND External Frame Grabber (900-6010) 1

Gigabit Ethernet desktop NIC 1

Ethernet cables 2

PoE injector (power supply) 1

eBUS SDK USB Stick 1
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Feature Set

*Case and junction temperature limits vary by IC device. For more information, see “Ambient and Junction 
Temperatures” on page 27.
**Approximate, excluding 12-pin GPIO connector.

CL-GigEB-IND CL-GigEB-IND

Order code 900-6010 900-6009

Device Model Name iPORT CL-GigE-PT01-CL0IP01-128x

Description Enclosed, industrial use OEM board set, industrial use

Camera Link mode Base Base

Channels Single Single

MiniCL connectors 1 1

External or PoE powered Yes Yes

PoCL Yes Yes

Operating temperature

• External powered: -40°C to 60°C

• PoE powered with PoCL off: -40°C to 55°C

• PoE powered with PoCL on: -40°C to 50°C

See note*

Storage temperature -40°C to 85°C

Dimensions (L x W x H) (mm)** 38 x 83 x 51 48.2 x 52 x 37 

Weight (grams) 161 47

GPIO  

LVDS/RS-422/HVTTL/±24V/±30V differential 
or TTL/LVCMOS single-ended inputs

2 2

TTL/LVCMOS single-ended inputs 2 2

TTL/LVCMOS single-ended outputs 3 3

MTBF at 40°C (hours) 1,014,151 1,014,151

Interface and transfer rate GigE interface with 1 Gb/s transfer rate

Standards compliance Compliant with Camera Link version 2.0 and GigE Vision version 2.0

Regulatory compliance RoHS2; REACH

Tap support 1 and 2 tap (dependent on selected pixel format)

Pixel clock 20 MHz to 85 MHz

Frame buffer
128 MB (120 MB is used for the frame buffer, 8 MB is used for the CL-GigE 
firmware)

Serial communication
1 UART on Camera Link interface allows serial control of cameras using a 
computer application over the GigE connection
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Key GenICam Features

The CL-GigE supports the seven features mandated by the GigE Vision standard, along with many 
additional features. The following table lists these mandatory features along with some of the key 
GenICam features. The full list of features can be seen in the Device Control dialog box of Pleora’s eBUS 
Player application.

Table 3: Key GenICam Features

Feature Description

DeviceScanType Specifies the sensor scan type, such as areascan or linescan.

SensorDigitizationTaps Specifies the number of digitized samples output simultaneously by the 
camera.

WidthMax Specifies the maximum width of the image (in pixels).

HeightMax Specifies the maximum height of the image (in pixels).

Width Specifies the width of the image (in pixels).

Height Specifies the height of the image (in pixels).

OffsetX Specifies the horizontal image offset (in pixels).

OffsetY Specifies the vertical image offset (in pixels).

PixelFormat Specifies the format of the pixels provided by the camera.

ClConnectorSelector Selects the Camera Link interface to configure.

ClSafePowerActive Controls whether the SafePower protocol is active. SafePower is a 
protocol to prevent the CL-GigE from attempting to supply power to a 
conventional (non-PoCL) cable or camera.

ClSafePowerStatus Reports the status of the SafePower controller.
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Available Pixel Formats

The following table lists the pixel formats available on the CL-GigE.

Table 4: Available Pixel Formats

Taps Pixel Formats

1, 2 taps Mono8 (Default), Mono8s, Mono10, Mono10Packed, Mono12, Mono12Packed

1 tap Mono14, Mono16

1, 2 taps BayerGR8, BayerRG8, BayerGB8, BayerBG8

1, 2 taps BayerGR10, BayerRG10, BayerGB10, BayerBG10

1, 2 taps BayerGR12, BayerRG12, BayerGB12, BayerBG12

1, 2 taps BayerGR10Packed, BayerRG10Packed, BayerGB10Packed, BayerBG10Packed

1, 2 taps BayerGR12Packed, BayerRG12Packed, BayerGB12Packed, BayerBG12Packed

1 tap BayerGR16, BayerRG16, BayerGB16, BayerBG16

1 tap RGB8, BGR8

1, 2 taps SCF1WGWR8

1, 2 taps SCF1WGWR10

1, 2 taps SCF1WGWR12

1 tap SCF1WGWR14

1, 2 taps YUV411_8_UYYVYY

1 tap YUV422_8_UYVY

1 tap YUV8_UYV

1 tap YCbCr422_8_CbYCrY

1 tap YCbCr709_422_8_CbYCrY

1, 2 taps YCbCr709_411_8_CbYYCrYY
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Chapter 3

CL-GigE Connections
This chapter describes the CL-GigE connections, including connector details and pinout information. 
When the CL-GigE is powered, you can observe the status LEDs.

The following topics are covered in this chapter:

• “Connector and Switch Locations” on page 12

• “RJ-45 Locking Connectors” on page 13

• “Camera Link Connector” on page 13

• “Mapping of Camera Link Connector and 12-Pin GPIO Connector Inputs” on page 15

• “12-Pin GPIO Connector” on page 16

• “Mounting the 12-Pin GPIO Connector to an Enclosure Backplate” on page 17

• “Differential Type and I/O Level Switches” on page 19

• “Powering the CL-GigE” on page 23

• “Power Consumption” on page 25

• “Status LEDs” on page 26
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Connector and Switch Locations

The following figures and table describe the CL-GigE connectors and switches.

Camera Link connector

Differential Type switch

I/O Level switch

RJ-45 connector

12-pin GPIO 
connector

In mountable enclosure

In mountable enclosure OEM board set*

*GPIO board assembly with soldered 12-pin connector and flat flex cable shown.

I/O Level switch

Differential Type 

Camera Link connector (CL1)

OEM board set

switch

RJ-45 connector

12-pin GPIO
connector

(CL1)

Table 5: Connectors and Switches

Component Type Description

CL1 connector Miniature Camera Link 
(MiniCL) connector

Provides connection to a Camera Link Base camera. Serial communication on this 
connector is mapped to the Bulk0 serial communication interface of the CL-GigE.

When PoCL is enabled, the CL-GigE can supply 4 W at 12 V to the Camera Link 
connector, as outlined in the Camera Link Standard.

For more information, see “Camera Link Connector” on page 13.

GPIO connector 12-pin circular connector Provides power and I/O signals to the CL-GigE.

For more information, see “12-Pin GPIO Connector” on page 16.

RJ-45 connector RJ-45 Ethernet connector Interfaces the CL-GigE to Ethernet networks, as specified in IEEE 802.3.

The Ethernet interface can operate at 100 or 1000 Mbps, and supports Internet 
Protocol Version 4 (IPv4).

Differential Type 
switch

3-position DIP switch Selects the termination type for differential inputs.

For more information, see “Differential Type and I/O Level Switches” on page 19.

I/O Level switch 2-position DIP switch Selects the voltage for single-ended GPIO inputs and outputs (3.3 V or 5 V).

For more information, see “Differential Type and I/O Level Switches” on page 19.
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RJ-45 Locking Connectors

The CL-GigE supports the Type 090 RJ-45 locking connectors specified by the GigE Vision Standard, 
Mechanical Supplement, version 1.0 draft A. The enclosure includes threaded screw holes that comply with 
the connectors specified in the standard.

Camera Link Connector

The CL-GigE supports one Base Camera Link camera, which streams image data to the CL-GigE. The 
CL1 connector is used to connect a Camera Link camera to the CL-GigE using one standard Camera 
Link cable, as outlined in the Camera Link Standard. This connector can process up to 24 bits of data 
from the camera and provides the following Camera Link control signals, as outlined in the Camera Link 
Standard: CC1, CC2, CC3, and CC4.

Threaded screw holes

Camera Link 
connector (CL1)
13CL-GigE Connections



Powering a Camera using Power Over Camera Link (PoCL)

The CL-GigE can optionally supply power to a camera using PoCL, in accordance to the Camera Link 
Standard. When powered using PoCL, 4 W at 12 V is supplied to the Camera Link connector for 
compatible cameras.

When power is being supplied to the camera using PoCL, the PoCL1 status LED will be on. For more 
information about the status LEDs, see “Status LEDs” on page 26.

Voltage Drop Monitoring

The CL-GigE includes a Voltage Dropped state that monitors a voltage drop from 12 V to a voltage 
below 10.5 V for cameras using PoCL. If the voltage drops below 10.5 V for more than 
20 ms, the CL-GigE returns to the PoCL Sensing state.

For information about viewing the SafePower status and the status changes that occur, including PoCL 
Sensing, see “Enabling SafePower and PoCL” on page 58.

Mapping to the Serial Communication Interface

The CL1 Camera Link connector is mapped to the Bulk0 serial communication interface on the 
CL-GigE.

To enable PoCL and to prevent the CL-GigE from attempting to supply power to a non-PoCL cable or camera, 
you must enable the ClSafePowerActive feature using eBUS Player (or an application created with the 
eBUS SDK). For more information, see “Enabling SafePower and PoCL” on page 58.
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Mapping of Camera Link Connector and 12-Pin GPIO 
Connector Inputs

The GPIO pins on the 12-pin GPIO connector allow an external signal to control a Camera Link camera, 
and are typically used for triggering. For example, you can use a trigger to synchronize image capture from 
multiple cameras or to synchronize image capture with an external device.

Using the Programmable Logic Controller (PLC), you can map and modify the GPIO input signals 
(GPIO_IN3, GPIO_IN2, GPIO_IN1, and GPIO_IN0) to:

• the camera control output signals (CC1, CC2, CC3, CC4) on the CL1 connector; and

• the GPIO output signals (GPIO_OUT2, GPIO_OUT1, GPIO_OUT0) on the 12-pin GPIO 
connector.

There are 16 possible mappings of the GPIO signals. For more information, see “Handling GPIO, 
Camera Control, and PLC Input and Output Programming Signals” on page 29.

12-pin GPIO 

In mountable enclosure OEM board set*

*GPIO board assembly with soldered 12-pin connector and flat flex cable shown.

connector
12-pin GPIO
connector
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12-Pin GPIO Connector

The GPIO inputs and outputs on the 12-pin GPIO connector support a variety of differential and single-
ended inputs and outputs, such as HVTTL, LVDS, and LVCMOS.

The pinouts for the 12-pin GPIO connector are listed in the following table.

The manufacturer and part number are provided in “Material List” on page 100.

The mating connector is a Hirose 12-pin circular connector, part number HR10A-10P-12S(73).

Table 6: 12-Pin GPIO Connector Pinouts

Pin Function Type PLC signal Notes

1 RET Power return N/A Ground

2 VIN Power input N/A Protected by 600 W @ 1.0 ms PP 
Zener TVS, +/- 30 kV per KBM.

Receives 11.7 V to 13 V unfiltered 
DC input, up to 0.7 A.

3 GPIO_IN1- Differential input1 negative GpioIn1 Do not connect for single-ended 
operation. Pin 6 provides the 
single-ended connection.

4 GPIO_OUT2 Single-ended output GpioOut2

5 GND/EMI_GND Ground Signal ground

6 GPIO_IN1+ Differential input1 positive GpioIn1 Can be used as a single-ended 
input (optional).

7 GPIO_OUT1 Single-ended output GpioOut1

8 GPIO_IN0- Differential input0 negative GpioIn0 Do not connect for single-ended 
operation. Pin 10 provides the 
single-ended connection.

9 GPIO_OUT0 Single-ended output GpioOut0

10 GPIO_IN0+ Differential input0 positive GpioIn0 Can be used as a single-ended 
input (optional).
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Mounting the 12-Pin GPIO Connector to an Enclosure 
Backplate

The CL-GigE is optionally available with a removable 12-pin GPIO connector and the corresponding 
GPIO board that are suitable for mounting to a client-sourced enclosure.

To mount the 12-pin GPIO connector to an enclosure backplate

1. Insert the 12-pin connector through the external side of the backplate.

2. Secure with washer and hex nut.

3. Connect the GPIO board (12 holes) to the base pins of the 12-pin connector through the internal 
side of the backplate.

11 GPIO_IN3 Single-ended input GpioIn3

12 GPIO_IN2 Single-ended input GpioIn2

Table 6: 12-Pin GPIO Connector Pinouts (Continued)

Pin Function Type PLC signal Notes

GPIO board

12-pin connector

12-pin circular connector

Insertion

Lock washer

Hex nut

GPIO board

Pins (soldered to GPIO board)

20-pin FFC cable
Enclosure interiorBackplate of client-sourced enclosure
17CL-GigE Connections



4. Assemble the 12-pin GPIO connector to the GPIO board by lining up the pins with the GPIO 
board.

5. Solder the pins of the connector to the GPIO board for a secure connection.

When oriented correctly, the tab on the 12-pin connector is aligned with the small white dot on the GPIO 
board, as shown in the following figure. Please disregard the white numbering on the back of the GPIO 
board, as the pin numbers are labeled incorrectly in early versions of the product.

Tab

12-pin male connector

GPIO board and 12-pin 
male connector (assembled)

Tab location

12-pin male
connector

When lined up properly,
pin 9 and pin 1 on the 12-pin 
connector are inserted through

White dot

GPIO board and 12-pin 
male connector (assembled)

GPIO board

Line up tab between
the two bottom pins the bottom two pinholes
18 iPORT CL-GigE External Frame Grabber User Guide



Differential Type and I/O Level Switches

The Differential Type and I/O Level switches are used to configure the CL-GigE to work with single-
ended and differential inputs.

Warning:

To avoid damage to the CL-GigE and connected equipment (or reduced lifetime of the Differential Type 
switch), ensure you observe the following precautions:

• Set the Differential Type and I/O Level switches BEFORE you connect equipment and apply power to 
the CL-GigE.

• Do not set the Differential Type switch to HVTTL when you are using LVDS equipment.

• Do not change the Differential Type switch setting while the CL-GigE is powered or while devices are 
connected.

Differential Type switch

I/O Level switch

In mountable enclosure

OEM board set

Differential Type switch

I/O Level switch
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The Differential Type switch is used to select the differential and single-ended signal levels.

The I/O Level switch is used to select either 3.3 V LVCMOS or 5 V TTL operation, and is used with 
single-ended inputs and outputs.

The following table shows how the Differential Type and I/O Level switches can be set, based on the 
input type.

Table 7: Switch Settings Based on Input Type 

Input/output type
Set the Differential Type 
switch to...

Set the I/O Level switch 
to...

Single-ended inputs and 
outputs

LVCMOS DIFF 3.3 V

TTL DIFF 5 V

HVTTL/HVCMOS/HTL HVTTL N/A

Differential inputs LVDS LVDS N/A

RS-422 LVDS or DIFF N/A

+/-24 V or +/-30 V DIFF N/A

HVTTL DIFF LVDS

3.3V 5V
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Differential and Single-Ended Input/Output Specifications

The input and output specifications vary, depending on how the Differential Type and I/O Level 
switches are set, as listed in the following tables.

Warning:

To avoid damage to the CL-GigE and connected equipment (or reduced lifetime of the Differential Type 
switch), ensure you observe the following precautions:

• Set the Differential Type and I/O Level switches BEFORE you connect equipment and apply power to 
the CL-GigE.

• Do not set the Differential Type switch to HVTTL when you are using LVDS equipment.

• Do not change the Differential Type switch setting while the CL-GigE is powered or while devices are 
connected.

Table 8: GPIO Differential Input Specifications

Specifications Input type

Differential 
+/-24 V, 
+/-30 V, 
RS-422

Differential 
LVDS, RS-422 
with 100 Ohm 
termination

Differential 
used as single- 
ended HVTTL/
HVCMOS

Differential used 
as single-ended 
LVCMOS

Differential 
used as 
single-ended 
TTL

Differential input 
termination

10 K and 
50 pF in 
series

100 Ohm N/A N/A N/A

Single-ended 
input 
termination

Negative (-) 
input

47 K to 1/3 of I/O level 
(1.1 V for 3.3 V I/O level or 1.7 V 
for 5 V I/O level)

Do not connect to negative (-) input

Positive (+) 
input

100 K to CL-GigE GND

Input thresholds

Low

-200 mV (minimum), differential
-50 mV (typical), differential
0 mV (maximum), differential

<6.5 V <0.9 V <1.5 V

High +200 mV (maximum), differential
+50 mV (typical), differential
0 mV (minimum), differential

>9.5 V >1.3 V >1.9 V

Hysteresis 150 mV (typical)

Maximum delay 100 nsec 65 nsec 100 nsec 100 nsec 100 nsec

Minimum 
operation voltage

-30 V

Maximum 
operation voltage

+30 V
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Clamping voltage Below -42 V, over +42 V

ESD protection Up to class -4 (+/-15 kV)

EMI filtering Serial ferrite bead 120 Ohm @ 100 MHz

Table 9: GPIO Single-Ended Input Specifications

Specifications Input type

LVCMOS TTL

Termination 100 K to CL-GigE GND

Low threshold <0.8 V <1.5 V

High threshold >2.0 V >3.5 V

Maximum delay 8 nsec

Minimum voltage -0.5 V (absolute)

Maximum voltage 6.5 V (absolute)

ESD protection Up to class -4 (+/-15 kV)

EMI filtering Serial ferrite bead 120 Ohm @ 100 MHz

Table 10: GPIO Output Specifications

Specifications Output type

LVCMOS TTL

High level output 
current

+/-24 mA +/-32 mA

Output Voltage

High minimum 2.4 V (@24 mA) 3.8 V (@ 32 mA)

High maximum 3.5 V 5.3 V

Low maximum 0.55 V (@24 mA) 0.55 V (@ 32 mA)

Maximum delay 6.4 nsec

ESD protection Up to class -4 (+/-15 kV)

EMI filtering Serial ferrite bead 120 Ohm @ 100 MHz

Table 8: GPIO Differential Input Specifications (Continued)

Specifications Input type

Differential 
+/-24 V, 
+/-30 V, 
RS-422

Differential 
LVDS, RS-422 
with 100 Ohm 
termination

Differential 
used as single- 
ended HVTTL/
HVCMOS

Differential used 
as single-ended 
LVCMOS

Differential 
used as 
single-ended 
TTL
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Powering the CL-GigE

The CL-GigE can be powered using Power over Ethernet (PoE) which uses isolated PoE circuitry or 
through an external power supply.

Powering the CL-GigE Using PoE

One of the ways that you can power the CL-GigE is with PoE. When you power the CL-GigE this way, 
the PoE power source can be either a PoE power injector or a PoE-enabled GigE switch.

To power the CL-GigE using PoE

1. Ensure that the Camera Link camera and the CL-GigE are NOT receiving power.

2. Securely connect the Camera Link cable to the camera and the CL-GigE. 

Ensure that you tighten the screws to prevent the camera from being disconnected accidentally.

Important: Do not disconnect the Camera Link cable while the camera or CL-GigE are receiving 
power.

3. Connect the CL-GigE to a PoE power injector or a PoE-enabled GigE switch. Then, connect your 
computer to the PoE power injector or GigE switch.

4. Apply power to the camera:
• If you plan on powering the camera using PoCL, use eBUS Player to enable PoCL (using the 

ClSafePowerActive feature). For more information, see “Enabling SafePower and PoCL” on 
page 58.

• If you are not powering the camera using PoCL, connect the camera to a power supply.

Important Power Sequence Information

To avoid damage to the CL-GigE (and in some cases the connected equipment):

• If you are using single-ended and differential inputs, set the Differential Type and I/O Level switches 
BEFORE you connect equipment and BEFORE you apply power to the CL-GigE.

• Always power up the CL-GigE BEFORE the camera.

• Always power down the camera BEFORE the CL-GigE.
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Powering the CL-GigE Using an External Power Supply

Another way to power the CL-GigE is with a 12 V external power supply through the 12-pin GPIO 
connector. Optionally, you can purchase an external power supply from Pleora (part number 904-3905).

The CL-GigE can optionally supply power to a camera using PoCL. If the CL-GigE is powered by an 
external power supply and you supply power to the camera using PoCL, VIN must be in the range of 
11.7 V to 13 V to meet the requirements of the Camera Link Standard.

External Power Supply — Input Signals

The following table lists the input power signals for the CL-GigE from an external power supply using 
the 12-pin GPIO connector.

To power the CL-GigE using an external power supply

1. Ensure that the Camera Link camera and the CL-GigE are NOT receiving power.

2. Securely connect the Camera Link cable to the camera and to the CL-GigE.

Ensure that you tighten the screws to prevent the camera from being disconnected accidentally.

Important: Do not disconnect the Camera Link cable while the camera or CL-GigE are receiving 
power.

Tip: We recommend that you connect the CL-GigE to your computer’s NIC or a GigE switch 
before you apply power.

3. Supply 12 V power to the 12-pin GPIO connector on the CL-GigE.

Table 11: Input Signals from the 12-Pin GPIO Connector

Name Volts (V) Notes

VIN 11.7-13V Efficiency of power circuitry (including drops on Schottky diodes) is flat in this range.

Unfiltered DC power from an external power supply through the 12-pin GPIO connector. 
Reverse voltage protected, up to -30 VDC.

The CL-GigE generates all internal power rails from the VIN signal. A resident common 
mode filter allows the input to be unfiltered, directly from a switching wall plug power 
supply.

RET Ground Ground for VIN.

GND Ground 0 V relative to other voltages on the CL-GigE. 

Important Power Sequence Information

To avoid damage to the CL-GigE (and in some cases the connected equipment):

• If you are using GPIO inputs, set the Differential Type and I/O Level switches BEFORE you connect 
equipment and BEFORE you apply power to the CL-GigE.

• Always power up the CL-GigE BEFORE the camera.

• Always power down the camera BEFORE the CL-GigE.
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4. Apply power to the camera:
• If you plan on powering the camera using PoCL, use eBUS Player to enable PoCL (using the 

ClSafePowerActive feature). For more information, see “Enabling SafePower and PoCL” on 
page 58.

• If you are not powering the camera using PoCL, connect the camera to a power supply.

Power Consumption

Power consumption at room temperature using a BK Precision DC Regulated external power supply.

Power consumption at room temperature using PoE and a Cisco SG200-08P Ethernet switch. 

If you are not using PoCL, the camera’s ground must be electrically floating or attached to the 12 V external 
power supply ground.

Table 12: Power Consumption Using External Power Supply

Streaming
PoCL 
enabled

Pixel clock 
frequency 
(MHz)

Sensor 

digitization taps
Width Height

Pixel 
format

Data rate 
(Mbps)

Power 
(W)

No No 20 N/A N/A N/A N/A Idle 2.1

No No 42 N/A N/A N/A N/A Idle 2.1

No No 85 N/A N/A N/A N/A Idle 2.2

Yes No 20 1 1024 1024 Mono12 319 2.2

Yes No 42 1 1024 1024 Mono12 670 2.3

Yes No 85 1 1024 1024 Mono12 990 2.4

Table 13: Power Consumption Using PoE

Switch 
reading

Streaming
PoCL 
enabled

Pixel clock 
frequency 
(MHz)

Sensor 

digitization taps
Width Height

Pixel 
format

Data rate 
(Mbps)

Power 
(W)

No No 20 N/A N/A N/A N/A Idle 2.3

No No 42 N/A N/A N/A N/A Idle 2.3

No No 85 N/A N/A N/A N/A Idle 2.4

Yes No 20 2 1024 1024 Mono12 638 2.4

Yes No 42 2 1024 1024 Mono12 990 2.6

Yes No 85 2 1024 1024 Mono12 990 2.7
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Status LEDs

The CL-GigE has status LEDs that indicate the operating status of the network connection, PoCL, 
power, and firmware, as described in the following table.

PoCL1

Network connection

In mountable enclosure OEM board set

In mountable enclosure OEM board set

PoCL1

Network activity

Power/FPGA

Power/FPGA

Network activity
speed

Network connection
speed

Table 14: Status LEDs 

LED Description

Power/FPGA Green: The CL-GigE is receiving power and the main firmware load is being used.

Yellow: The CL-GigE is receiving power and the backup firmware load is being used.

Off: The CL-GigE is not receiving power.

Network activity Off: No Ethernet connection.

Green: Ethernet link.

Green, flashing: Data is being transmitted or received.

Network 
connection speed

Off: No connection, 10 Mbps connection, or 100 Mbps connection.

Green: 1 Gbps connection.

PoCL1 Green: Power over Camera Link (PoCL) is active and the camera is being powered using PoCL.

Off: The camera is not receiving power through PoCL.
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Chapter 4

Ambient and Junction Temperatures
This chapter provides you with the information you need to ensure the optimal operating temperature 
for your CL-GigE OEM board set.

This chapter lists the components that consume the largest amount of power on the 
CL-GigE OEM board set, and will therefore be most affected by high temperatures. You must provide a 
method to cool these components using a heat sink or thermal pad.

You should store the CL-GigE at temperatures between -40°C to +85°C.

Table 15: Thermal Guidelines, OEM Board Set

Reference 
designator 
and location

Component and 
manufacturer part 
number

Rating for component on standard Pleora product*

U2, GigE PHY 
board

Marvell PHY

Part number: 88E1510-
A0-NNB2I000

Ambient: -40°C to +85°C

Junction: -40°C to +125°C

Case: Not specified

Junction-to-case thermal resistance ΘJC: 18.6 (°C/W)

Junction-to-ambient thermal resistance ΘJA:

• Still air: 35.2 (°C/W)

• 1 m/sec: 30.5 (°C/W)

• 2 m/sec: 29.3 (°C/W)

• 3 m/sec: 28.4 (°C/W)

Power consumption: ~ 450 mW
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* ΘJC = (Tj - Ta)/Ptop, where Ptop = Power dissipation from the top of the package.

   ΘJA = (Tc - Ta)/P, where P = Total power dissipation.

U2, FPGA 
board

ISSI DDR3

Part number: 
IS43TR16640A-15GBLI

Ambient: Not specified

Junction: Not specified 

Case: -40°C to +95°C

Junction-to-case thermal resistance ΘJC: Not specified

Junction-to-ambient thermal resistance ΘJA: Not specified

Power consumption: ~ 130 mW at 1Gbps streaming.

U1, FPGA 
board

Altera FPGA 

Part number: 
5CEFA4U19I7N

Ambient: Not specified 

Junction: -40°C to +100°C

Case: Not specified

Junction-to-case thermal resistance ΘJC: 5 (°C/W)

Junction-to-ambient thermal resistance ΘJA:

• Still air: 23.6 (° C/W)

• 100 ft./min: 19.5 (°C/W)

• 200 ft./min: 17.5 (°C/W)

• 400 ft./min: 15.9 (°C/W)

Power consumption:

• ~ 980 mW

Table 15: Thermal Guidelines, OEM Board Set (Continued)

Reference 
designator 
and location

Component and 
manufacturer part 
number

Rating for component on standard Pleora product*
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Chapter 5

Handling GPIO, Camera Control, and PLC Input and 
Output Programming Signals

The CL-GigE includes a programmable logic controller (PLC) that lets you control external machines 
and react to inputs. By controlling your system using the PLC, you can make functional changes, adjust 
timing, or add features without having to add new hardware.

If your system includes a quadrature encoder, you can process its signals and produce trigger signals for 
the camera using the CL-GigE’s PLC, as described later in this chapter. 

The following topics are covered in this chapter:

• “PLC Input and Output Programming Signals” on page 30

• “Using Quadrature Encoders” on page 32

• “Differential Connection” on page 33

• “Single-Ended Connection” on page 33

• “Processing Quadrature Encoder Signals” on page 34

For an introduction to the PLC and for detailed information about how PLC signals are handled, see the 
iPORT Advanced Features User Guide, available on the Pleora Support Center at 
supportcenter.pleora.com.
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PLC Input and Output Programming Signals

The following table lists the PLC input and output programming signals and indicates the pins on which 
they are available.

Table 16: PLC Signal Usage

Signal name PLC equation usage
Associated pin on the 12-pin 
GPIO connector

Camera Link connector

Pb0Fval In No associated pin

Pb0Lval In No associated pin

Pb0Dval In No associated pin

Pb0Spare In No associated pin

GpioIn0 In Pin 10 (GPIO_IN0+), 8 (GPIO_IN0-)

GpioIn1 In Pin 6 (GPIO_IN1+), 3 (GPIO_IN1-)

GpioIn2 In Pin 12 (GPIO_IN2)

GpioIn3 In Pin 11 (GPIO_IN3)

BufferWM0 In No associated pin

Grb0AcqActive In No associated pin

PlcCtrl0 In No associated pin

PlcCtrl1 In No associated pin

PlcCtrl2 In No associated pin

PlcCtrl3 In No associated pin

Pb0CC0 In, out No associated pin CC1

Pb0CC1 In, out No associated pin CC2

Pb0CC2 In, out No associated pin CC3

Pb0CC3 In, out No associated pin CC4

GpioOut0 In, out Pin 9 (GPIO_OUT0)

GpioOut1 In, out Pin 7 (GPIO_OUT1)

GpioOut2 In, out Pin 4 (GPIO_OUT2)

PlcFval0 In, out No associated pin

PlcLval0 In, out No associated pin

PlcMval0 In, out No associated pin

PlcTrig0 In, out No associated pin

PlcTimestampCtrl In, out No associated pin

Timer0Trig In, out No associated pin
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* Available in release 1.3.1 (and later) of the CL-GigE firmware.

Timer0Out In No associated pin

Timer1Trig In, out No associated pin

Timer1Out In No associated pin

Timer2Trig* In, out No associated pin

Timer2Out* In No associated pin

Timer3Trig* In, out No associated pin

Timer3Out* In No associated pin

Counter0Reset In, out No associated pin

Counter0Inc In, out No associated pin

Counter0Dec In, out No associated pin

Counter0Eq In No associated pin

Counter0Gt In No associated pin

Counter1Reset In, out No associated pin

Counter1Inc In, out No associated pin

Counter1Dec In, out No associated pin

Counter1Eq In No associated pin

Counter1Gt In No associated pin

Rescaler0In In, out No associated pin

Rescaler0Out In No associated pin

Delayer0In In, out No associated pin

Delayer0Out In No associated pin

Event0 In, out No associated pin

Event1 In, out No associated pin

Event2 In, out No associated pin

Event3 In, out No associated pin

ActionTrig0 In No associated pin

ActionTrig1 In No associated pin

Table 16: PLC Signal Usage (Continued)

Signal name PLC equation usage
Associated pin on the 12-pin 
GPIO connector

Camera Link connector
31Handling GPIO, Camera Control, and PLC Input and Output Programming Signals



Using Quadrature Encoders 

Quadrature encoder sensors produce electrical signals that indicate the direction, speed, and motion of 
the processed material on the web or conveyor systems. These signals are often used to control camera 
triggering to provide uniform images under varying load conditions. The quadrature encoder’s signals are 
typically processed by an external frame grabber that produces a trigger signal for the camera.

Quadrature encoders have a solid or hollow shaft that is mechanically connected to a motor or rotating 
apparatus on the web or conveyor system. Two-phase quadrature encoders have two outputs labeled A 
and B, which produce square wave signals when the shaft is rotating. These signals are 90° out-of-phase. 
When the shaft changes rotation between clockwise and counter-clockwise directions, these signals 
change phasing between +90° and -90°.

Figure 1: Two-Phase Quadrature Encoder Signals

This change is used to detect direction of motion. The rate of the square wave signals is proportional to 
the rotation speed of the shaft. This change is also used for detecting speed of motion. When these signals 
are steady-state, and are not producing square wave signals, the motion has stopped.

For information about the electrical interface on the CL-GigE, see “Differential Type and I/O Level Switches” 
on page 19.
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Differential Connection

The following diagram illustrates a typical differential connection to a quadrature encoder.

Figure 2: Typical Differential Connection to Quadrature Encoder

Single-Ended Connection

The following diagram illustrates a typical single-ended connection to a quadrature encoder.

Figure 3: Typical Single-Ended Differential Connection to Quadrature Encoder

A
GPIO_IN0+

Pin 10 on 12‐pin connector

B

GPIO_IN0‐
Pin 8 on 12‐pin GPIO connector

GPIO_IN1+ 
Pin 6 on 12‐pin GPIO connector

GPIO_IN1‐ 
Pin 3 on 12‐pin GPIO connector

N/C

N/C

Industrial Models
Differential Inputs

Quadrature Encoder
Single‐Ended Outputs

GpioIn0

GpioIn1

+

‐

+

‐

VREF
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Timer0 is configured with the following settings to generate a trigger pulse. These values may need to be 
adjusted depending on the selected camera model and system requirements.

The signal routing block in the PLC is configured using the Boolean expressions below. GpioIn0 is signal 
A and GpioIn1 is signal B. Note that "!" in the Boolean expressions represents not or inverted.

Processing Quadrature Encoder Signals

This section provides an example of how you can using the CL-GigE’s PLC to process signals from a 
quadrature encoder.

Example: Connect GpioIn0 and GpioIn1 to quadrature encoder outputs A and B, respectively. 

In this example, images are captured only when the conveyor belt or web is moving in the forward 
direction. When the conveyor belt or web moves in the forward direction, signal A leads signal B by 90°. 
When the conveyor belt moves in the reverse direction, signal A lags signal B by 90°. The PLC provides 
a trigger signal on the Camera Link control line Pb0CC0 only when signal A leads signal B by 90°.

Table 17: PLC Timer Equations

Equation Description

TimerTriggerSource = TriggerInput Sets the triggering source for the Timer to be its external trigger 
input.

TimerTriggerActivation = FallingEdge Sets the Timer to trigger on the external source’s falling edge.

TimerGranularityFactor = Granularity30ns Sets the interval of the Timer’s internal clock tick. For this example, 
we recommend that the selected factor be at least 8x smaller than 
the period of the highest frequency expected from the quadrature 
encoder.

TimerDelayRaw = 1 Sets the delay time before the pulse can start. This is the low period 
of the pulse after the trigger. This value represents the number of 
Timer internal clock ticks.

TimerDurationRaw = 6 Sets the duration or high time of the pulse. This value represents the 
number of internal clock ticks.

Table 18: Signal Routing Block Equations

Equation Description

Timer0Trig = GpioIn0 & !GpioIn1 Generates the trigger signal for Timer0 from signals A and B.

Pb0CC0 = !(Timer0Out & GpioIn0) Masks the trigger for the camera when the conveyor belt or web 
moves in the reverse direction.
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The Timer0 function in the PLC is used to generate the trigger pulse Timer0Out. Timer0 itself is 
triggered by the falling edge of a Boolean combination of A and B signals, which obtains the correct 
quadrature phase for the forward direction. Another Boolean combination is used to produce the trigger 
signal Pb0CC0 from signal B and Timer0Out; when the conveyor belt or web moves in the reverse 
direction, signal B masks the trigger pulse Timer0Out.

The following table provides recommendations for using quadrature encoders.

Table 19: Quadrature Encoder Recommendations

Encoder output type Encoder output GPIO input Notes

Differential A Differential Input0 positive, pin 
10 on the 12-pin connector

PLC signal name: GpioIn0

Differential Input0 negative, pin 8 
on the 12-pin connector

B Differential Input1 positive, pin 6 
on the 12-pin connector

PLC signal name: GpioIn1

Differential Input1 negative, pin 3 
on the 12-pin connector

Single-ended A Differential Input0 positive, pin 
10 on the 12-pin connector

PLC signal name: GpioIn0

Differential Input0 negative, pin 
8 is not connected

B Differential Input1 negative, pin 6 
on the 12-pin connector

PLC signal name: GpioIn0

Differential Input1 negative, pin 
3 is not connected
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Chapter 6

Bulk Interfaces
The CL-GigE has one UART interface for serial communication with a connected Camera Link camera.

The following topics are covered in this chapter:

• “GenICam Interface for Serial Communication Configuration” on page 38

• “UART Timing” on page 38
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GenICam Interface for Serial Communication Configuration

The following GenICam features are available for serial communication configuration.

UART Timing

The UART interface supports:

• 8-bit data transfer

• 1 start bit

• Programmable stop bit(s): 1 or 2 stop bits

• Parity: None, Even, or Odd

• Baud rates:

• Predefined rates: 9600, 14 400, 19 200, 28 800, 38 400, 57 600, 115 200, 230400*, 460800*, 
and 921,600*

• Programmable

• Loop back mode from downstream to upstream

*Available in release 1.3.1 (and later) of the CL-GigE firmware.

Figure 4: UART Timing

Table 20: GenICam Features Available for Serial Communication 

Feature Description

BulkSelector Selects Bulk0 for configuration.

BulkBaudRate Selects a predefined Baud rate or programmable option.

BulkBaudRateFactor Programs a user-defined Baud rate.

BulkLoopback Loops back downstream data to upstream direction (loops the data back to the 
computer).

BulkNumOfStopBits Selects a stop bit option (either 1 or 2).

BulkParity Selects a parity option (None, Even, or Odd).

BulkUpstreamFifoWatermark Controls the number of bytes to accumulate in the Bulk interface upstream FIFO 
before the CL-GigE delivers them to the host using an event type packet.
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A number of preset baud rates can be used. If you require a baud rate that is not covered by the presets, 
you can specify your own baud rate. To specify your own baud rate:

1. In the Device Control dialog box, under Port Communication, choose Programmable in the 
BulkBaudRate list.

2. In the BulkBaudRateFactor field, enter a baud rate between 1 and 511. 

The CL-GigE calculates the baud rate using the following equation: 
(66.666666 MHz * 1000000)/(BulkBaudRateFactor * 16)

*Available in release 1.3.1 (and later) of the CL-GigE.

*Available in release 1.3.1 (and later) of the CL-GigE.

The following table provides the A.C. operating characteristics of the UART interface.

Table 21: UART Baud Rates

Baud rate (BR) [bps] Notes

9,600 Preset 0 (default)

14,400 Preset 1

19,200 Preset 2

28,800 Preset 3

38,400 Preset 4

57,600 Preset 5

115,200 Preset 6

230,400* Preset 7

460,800* Preset 8

921,600* Preset 9

Maximum BulkBaudRateValue (when BulkBaudRateFactor is set to 1): 4,166,667
Minimum BulkBaudRateValue (when BulkBaudRateFactor is set to 511): 8,154

Programmable baud rate

Table 22: A.C. Operating Characteristics of the UART Interfaces

Parameter Symbol Min Max Units Notes

Data period tUART 0.240 122.64 μs

Baud rate BR 8 154 4 166 667 bps 1/tUART
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Chapter 7

Installing the eBUS SDK
This chapter describes how to install the eBUS SDK, and also provides information about installing the 
GigE Vision driver.

The following topics are covered in this chapter:

• “Installing the eBUS SDK” on page 41

• “Installing the eBUS Universal Pro Driver” on page 42

Installing the eBUS SDK

You can install the Pleora Technologies eBUS SDK on your computer to configure and control your 
CL-GigE.

The eBUS SDK includes:

• Pleora’s eBUS Player application, which allows you to control the CL-GigE parameters and view 
video from a video source connected to the CL-GigE. 

• An extensive library of sample applications, with source code, to create working applications for 
device configuration and control, image and data acquisition, and image display and diagnostics. 

• Drivers that optimize the performance of your system.

It is possible for you to configure the CL-GigE and GigE Vision compliant video sources using other 
GenICam compliant software, however, this guide provides you with the instructions you need to use the 
Pleora eBUS Player application.
Installing the eBUS SDK 41



Installing the eBUS Universal Pro Driver

The eBUS SDK includes a GigE Vision driver that enhances existing general-purpose drivers shipped 
with NICs, increases image acquisition throughput and performance, decreases latency and jitter, and 
minimizes CPU utilization.

To use the eBUS Driver Installation Tool

1. Click Start > All Programs > eBUS SDK > eBUS Driver Installation Tool.

2. Under GigE Vision, click Install or Uninstall.

After a moment the driver status changes. If you are installing a driver, the driver is installed across 
all network adapters on your computer.

3. Close the eBUS Driver Installation Tool.

You may be required to restart your computer.

The USB3 Vision driver, which is available during the installation of the eBUS SDK, is for use with USB3 
Vision compliant devices, such as the Pleora CL-U3 External Frame Grabber.

The drivers are selected for installation by default during the eBUS SDK installation process. If you choose 
not to install the drivers (or want to uninstall either driver), you can use the eBUS Driver Installation Tool.

To see the versions of the installed drivers, click Help > About.
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Chapter 8

Configuring Your Computer’s NIC for use with the 
CL-GigE

When using the CL-GigE and connected Camera Link camera, you may observe high data rates (above 
800 Mb/s) that are close to the physical limit of Gigabit Ethernet (1000 Mb/s). This chapter provides 
guidance on how to configure your CL-GigE to maximize the performance of your system.

The following topics are covered in this chapter:

• “Configuring the NIC for Communication with the CL-GigE” on page 44

• “Calculating the Required Bandwidth” on page 46

• “Understanding the Factors that can Effect Bandwidth and Performance” on page 46
Configuring Your Computer’s NIC for use with the CL-GigE 43



Configuring the NIC for Communication with the CL-GigE

For optimal performance, we recommend that you enable jumbo packets (also known as jumbo frames) 
and set the receive descriptors to the maximum available value.

To configure the NIC for optimal performance

1. In the Windows Control Panel, click Network and Internet.

2. Click Network and Sharing Center.

The instructions in this section are based on the Windows 10 operating system. The steps may vary 
depending on your computer’s operating system.
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3. In the left-hand panel, click Change adapter settings.

4. Configure the NIC for jumbo packets (more often referred to as jumbo frames) and set the NIC’s 
Receive Buffers (Receive Descriptors) to the maximum available value. Using jumbo packets allows 
you to increase system performance. However, you must ensure your NIC and GigE switch (if 
applicable) support jumbo packets.

To complete this task, right-click the NIC and click Properties. Then, click Configure. The exact 
configuration procedure, as well as the jumbo packet size limit, depends on the NIC.

5. Close the open dialog boxes to apply the changes and close the Control Panel.
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Calculating the Required Bandwidth

To calculate the approximate bandwidth that is required, use the following formula. Keep in mind that 
this calculation results in an approximate value, and does not take into account Ethernet, IP, UDP, and 
GigE Vision overhead. Note that each image is broken up into many packets, which should be considered 
when determining overhead.

For example, for a CL-GigE configured with 1280 x 720, a 16-bit pixel format, and a PayloadSize of 
1.84 MB at 60 frames per second, the equation would look like this:

Understanding the Factors that can Effect Bandwidth and 
Performance

This section provides a summary of the features that you can adjust to maximize the bandwidth and 
performance of your system. For detailed information, see the Configuring Your Computer and Network 
Adapters for Best Performance knowledge base article, available on the Pleora Support Center at 
supportcenter.pleora.com.

Width, Height, and Pixel Format

The Width, Height, and PixelSize have a direct effect on the bandwidth that is used between the 
CL-GigE and the computer. Increasing the width and the height of the image will result in larger frames 
being streamed from the CL-GigE.

PayloadSize is automatically calculated by the CL-GigE, based on the selected image settings, which 
include Width, Height, OffsetX, OffsetY, PixelSize, and any padding that has to be added to the image 
payload. To see the PayloadSize, open eBUS Player, connect to the CL-GigE, and then click Device control. 
PayloadSize appears in the TransportLayerControl category.

PayloadSize (MB) x 8 x Frames Per Second = Bandwidth (Mbps)

1.84 MB x 8 x 60 Hz = 883.2 Mbps

If you experience streaming errors or warnings, such as AUTO_ABORTED, MISSING_PACKETS, or 
BlocksDropped, see the Stream Control Application Note, available on the Pleora Support Center.
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Acquisition Frame to Skip

If the CL-GigE drops frames because of high bandwidth usage (close to 1 gigabit), you can reduce the 
bandwidth by adjusting the AcquisitionControl\AcquisitionFrameToSkip feature.

Packet Size

To decrease the CPU resources required to reassemble full frames, you can increase the 
GevSCPSPacketSize. Doing so increases the size of each packet, resulting in fewer packets, thereby 
reducing the amount of CPU resources that are used for packet reassembling. Depending on the 
GevSCPSPacketSize you choose, you may need a NIC that supports jumbo packets.

You can also set the AutoNegotiation feature to True, which allows the eBUS SDK to negotiate the largest 
packet size that the computer can receive. When acquisition starts, you can see the value that was 
negotiated for the GevSCPSPacketSize feature.

On some occasions, your computer may display a Connection Lost error. This can occur when a NIC 
does not properly support jumbo packets. If this occurs, you can either disable jumbo packets on the NIC 
or disable the AutoNegotiation feature and set the DefaultPacketSize manually.

You can set this feature to 2 to skip two frames and then send one frame, resulting in one out of every three 
frames being sent, for example.

Please note that if you execute the DeviceReset command, the GevSCPSPacketSize is reset to 576. To 
avoid this limitation, you can set the GevSCPSPacketSize manually or override this feature using the User 
Set. The User Set is a feature that lets you save the changes you make to your CL-GigE settings. For more 
information, see “Saving eBUS Player and CL-GigE Settings” on page 67.
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Chapter 9

Connecting to the CL-GigE and Configuring General 
Settings Using eBUS Player

After you have set up the physical connections to the CL-GigE, you can start eBUS Player to configure 
image settings, which will help ensure that images are received and displayed properly. You can also 
configure the buffer options to reduce the likelihood of lost packets.

The following topics are covered in this chapter:

• “Confirming Image Streaming” on page 50

• “Providing the CL-GigE with an IP Address” on page 52

• “Configuring the CL-GigE with an Automatic/Persistent IP Address” on page 52

• “Accessing your Camera Settings through Camera Link Serial Communications” on page 54

• “Configuring CL-GigE Image Settings Using eBUS Player” on page 55

• “Enabling SafePower and PoCL” on page 58

• “Viewing and Testing Streaming Images” on page 60

• “Configuring the Buffers” on page 61

• “Specifying How Images are Acquired” on page 62

• “Implementing the eBUS SDK” on page 66

BEFORE you attempt to stream images, you must know the image settings of your Camera Link camera, 
and then configure the CL-GigE with matching image settings.
Connecting to the CL-GigE and Configuring General Settings Using eBUS Player 49



Confirming Image Streaming

After the CL-GigE is physically connected to the computer, use eBUS Player with the test pattern feature 
enabled to verify that the CL-GigE can stream properly to the computer. 

After you have confirmed that eBUS Player is receiving the test pattern from the CL-GigE, disable the 
test pattern so that the CL-GigE can stream images from the camera.

To start eBUS Player and connect to the CL-GigE

1. Start eBUS Player from the Windows Start menu.

2. Click Select/Connect.

If the CL-GigE does not appear in the list that appears, click the Show unreachable Network 
Devices check box to show all devices.

3. In the Device Selection dialog box, click the CL-GigE and then click OK.

4. In the Camera Control dialog box that appears, click Manual (other communication methods for 
the camera include CL Protocol library and GenCP).

5. Under How is your camera powered, choose one of the following options:
• My camera has an external power supply. Selecting this option sets the ClSafePowerActive 

feature* to False.
• Power is provided by the frame grabber Camera Link cable (PoCL). Selecting this option sets 

the ClSafePowerActive feature* to True.

* The ClSafePowerActive feature enables the SafePower protocol on the CL-GigE so it can supply 
power using PoCL. This protocol also prevents the CL-GigE from attempting to supply power to 
a camera that does not support PoCL.

6. Click OK.

eBUS Player is now connected to the CL-GigE.

For detailed instructions about how to use eBUS Player, see the eBUS Player for Windows and Linux User 
Guide available on the Pleora Support Center at supportcenter.pleora.com.

If the IP address is not compatible with the NIC, a warning ( ) appears in the Device Selection dialog 
box. Provide the CL-GigE with an IP address, as outlined in “Providing the CL-GigE with an IP Address” on 
page 52.
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To turn the test pattern on or off

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. Under Parameters and Controls, click Device control.

3. Under ImageFormatControl, click a test pattern option in the TestPattern list.

4. Close the Device Control dialog box.

When the test pattern is enabled and you click Play, you will see an image similar to this (the pattern 
and colors may vary, depending on the image settings).
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Providing the CL-GigE with an IP Address

The CL-GigE requires an IP address to communicate on a video network. This address must be on the 
same subnet as the computer that is performing the configuration and receiving the image stream.

To provide the CL-GigE with an IP address

1. Start eBUS Player.

2. Click Select/Connect.

3. Click the CL-GigE.

If the CL-GigE does not appear in the list, click the Show unreachable Network Devices check box 
to show all devices.

If the IP address is not compatible with the NIC, a warning ( ) appears in the Device Selection 
dialog box.

4. Click Set IP Address.

5. Provide the CL-GigE with a compatible IP address and subnet mask. You can optionally provide a 
default gateway.

Note that this information is temporary and is reset when you power down the CL-GigE. To set an 
IP address that is used permanently, see the next procedure in this guide.

6. Click OK to close the Set IP Address dialog box.

7. Click OK to close the Device Selection dialog box and connect to the CL-GigE.

Configuring the CL-GigE with an Automatic/Persistent IP Address

The Device Control dialog box allows you to configure a persistent IP address for the CL-GigE. 
Alternatively, the CL-GigE can be configured to automatically obtain an IP address using Dynamic Host 
Configuration Protocol (DHCP) or Link Local Addressing (LLA). The CL-GigE uses its persistent IP 
address first, but if this option is set to False, it can be configured to attempt to obtain an address from a 
DHCP server. If this fails, it will use LLA to find an available IP address. LLA cannot be disabled and is 
always set to True.

To configure a persistent IP address

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. Under Parameters and Controls, click Device control.

If you are using a unicast network configuration, the management entity/data receiver and the CL-GigE 
must be on the same subnet. The unicast network configuration is outlined in “Unicast Network 
Configuration” on page 74.

The CL-GigE can use the persistent IP address each time it is powered up as long as the IP address is valid 
and there are no IP address conflicts
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3. Under TransportLayerControl\GigEVision, set the GevCurrentIPConfigurationPersistentIP 
feature to True.

4. Set the GevPersistentIPAddress feature to an IP address that is compatible with your computer’s 
NIC.

5. Set the GevPersistentSubnetMask feature to a compatible subnet mask address.

6. Optionally, enter a compatible default gateway in the GevPersistentDefaultGateway field.

7. Close the Device Control dialog box.

8. Disconnect the camera from the CL-GigE, power cycle the CL-GigE, and reconnect the camera.

To automatically configure an IP address

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. Under Parameters and Controls, click Device control.

3. Under TransportLayerControl\GigEVision, set the GevCurrentIPConfigurationPersistentIP 
feature to False.

4. Set the GevCurrentIPConfigurationLLA and/or GevCurrentIPConfigurationDHCP values to 
True, depending on the type of automatic addressing you require.

5. Close the Device Control dialog box.

6. Disconnect the camera from the CL-GigE, power cycle the CL-GigE, and reconnect the camera.
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Accessing your Camera Settings through Camera Link Serial 
Communications

You can use eBUS Player to send serial commands between the CL-GigE and the Camera Link camera. 
For a list of commands that can be sent to the camera, consult the camera’s technical documentation.

To send serial commands to your camera using eBUS Player

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. On the Tools menu, click Device Serial Communication.

3. In the Port Selection list, ensure the bulk port is selected.

4. In the Speed list, select the baud rate that matches your camera.

Tip: If you need to set the parity and stop bits, click Device control on the main page of eBUS 
Player. In the Visibility list, click Guru. Under IP Engine > PortCommunication, set the values for 
these options.

This section explains how to send serial commands between the CL-GigE and the camera. Alternatively, you 
can establish a serial bridge or camera bridge to communicate with your camera using serial 
communication.

The following options are available:

• GenCP communication, for cameras that are GenCP compliant.

• Serial port (COM port) communication, which you will use if your camera manufacturer has provided a 
software application that assumes that you use a serial port on your computer to send serial 
commands to the camera.

• Camera Link DLL, which you will use if your camera manufacturer has provided a software application 
that uses a Camera Link DLL to send serial commands to the camera.

• GenICam CLProtocol library, which you will use if you have a CLProtocol DLL (provided by the camera 
manufacturer).

For information about using these serial communication methods, see the knowledge base article titled 
Introduction: Establishing a Serial Bridge on the Pleora Support Center at supportcenter.pleora.com.
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5. Under Send as, select the data transmission sequence format by clicking either ASCII (text only) or 
Hexadecimal.

6. Type the data string in the Data box.

For hexadecimal, enter a pair of hexadecimal digits for each byte, separated by spaces. For example, 
01 23 45 67 89 AB CD EF.

7. Select one of the trailer options beside Append.

Trailer options are not mutually exclusive; they append in the order shown.

Select Other for ASCII and hexadecimal sequences in custom trailers for devices that do not use the 
trailer options in the order shown, for example, CR and LF.

8. Click Send to transmit the data sequence.

9. Wait for the device to reply.

10.Close the Device Serial Communication dialog box.

Configuring CL-GigE Image Settings Using eBUS Player

After you have configured your Camera Link Camera with optimal image settings, you must configure 
matching image settings on the CL-GigE. 

Take note of the camera’s image settings

Take note of the camera’s image settings. You can find this information by consulting the camera’s 
technical documentation or by using the camera configuration software that accompanies your camera.

• Scan type (area scan or line scan)

• Number of taps (sometimes referred to as tap geometry or sensor digitization taps)

• Image width

The changes that you make to your CL-GigE are temporary and will not persist across power cycles. To 
understand more about how to save your settings, see “Saving eBUS Player and CL-GigE Settings” on page 
67.
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• Image height

• Pixel bit depth (8, 10, 12 bits, or more)

• Pixel format

These settings may not be available in the software; you may need to use the camera’s technical 
documentation to find this information. If you cannot find the pixel format, you should start by 
configuring the CL-GigE to use a Mono (monochrome) setting.

• Power source (from a power supply or PoCL)

To ensure the CL-GigE is streaming images properly, you must configure the CL-GigE’s image settings 
to match those previously configured on the camera.

To configure image settings on the CL-GigE

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. In the Visibility list, click Expert.

3. Under DeviceControl, select a sensor scan type (areascan or linescan) in the DeviceScanType list.

4. Under ImageFormatControl, select the number of taps in the SensorDigitizationTaps list.
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5. Under ImageFormatControl, enter the image width and height, and select a pixel format from the 
PixelFormat list.

6. Close the Device Control dialog box.

7. Click Play to see the changes.

DeviceScanType, SensorDigitizationTaps, PixelFormat, and TestPattern are interrelated. When you 
change any of these values, the CL-GigE may automatically adjust the other values to ensure the 
configuration is valid.
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Enabling SafePower and PoCL

To allow the CL-GigE to supply power to a Camera Link camera using PoCL, enable the 
ClSafePowerActive feature. When this feature is enabled, PoCL is active and the SafePower protocol is 
used, which prevents the CL-GigE from attempting to supply power to a non-PoCL cable or camera.

To enable SafePower and PoCL and to view the PoCL status

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. In the Visibility list, click Expert or Guru.

3. Under CameraLinkInterfaceControl, select Connector1 in the ClConnectorSelector list.

4. In the ClSafePowerActive list, click True to enable SafePower and PoCL.
58 iPORT CL-GigE External Frame Grabber User Guide



5. Review the status that appears under ClSafePowerStatus. The following flowchart explains the 
status changes.
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Viewing and Testing Streaming Images

You can view and test your image settings using eBUS Player.

To view streaming images in eBUS Player

1. Start eBUS Player and connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

2. Under Acquisition Control, select the acquisition mode you want to use to acquire images. By 
default, images are streamed in Continuous mode (the CL-GigE sends a stream of continuous 
images instead of a single image).

For other acquisition modes, see “Specifying How Images are Acquired” on page 62.

3. Click Play. 

The images appear in the Display section of eBUS Player.

To view images from the camera, the test pattern must be disabled. For more information, see “To turn the 
test pattern on or off” on page 51.

If images or the test pattern do not stream, see the tips provided in “System Troubleshooting” on page 83.

Example image. When the test pattern is enabled for the CL-GigE, a stream of moving lines will appear
(often black, gray, and white) instead of video from your camera.
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Configuring the Buffers

You can increase the buffer count using eBUS Player to make streaming more robust. A high number of 
buffers are needed in high frame rate applications, while a small number of buffers are needed for lower 
frame rates. Latency increases as the number of buffers increases.

To configure the buffers

1. Start eBUS Player. 

2. Click Tools > Buffer Options.

3. Click the buffer option that suits your requirements.

4. Click OK.

Default size for streaming is 16 buffers.
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Specifying How Images are Acquired

Continuous, SingleFrame, and MultiFrame modes are usually standard for external frame grabbers. 
Acquisition starts when the Play button is pressed (the AcquisitionStart command is executed).

Continuous Mode

This mode allows you to acquire images continuously and is the default mode for most external frame 
grabbers.

eBUS Player Main Page

Device Control Dialog Box
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Mulitframe Mode

This mode allows you to acquire a fixed number of images. To configure the number of images, set the 
CL-GigE’s AcquisitionControl > AcquisitionFrameCount feature.

You can set the AcquisitionControl > AcquisitionFrameCount feature in the Device Control dialog box, 
as shown in the following image.

SingleFrame Mode

This mode allows you to acquire a single image. 
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Recording and Retrieving Images in the Onboard Memory

The recording acquisition modes allow you to capture images from a camera and store them in the 
CL-GigE’s onboard memory. The readout acquisition modes allow images to be acquired from the 
CL-GigE’s memory at a slower rate, ensuring images are not lost. 

These modes are helpful when you are working with a camera that transmits images at a rate that exceeds 
the connection between the CL-GigE and the computer, resulting in dropped images. For example, a Base 
Configuration Camera Link camera transmits images at up to 2.04 Gbps (2 taps, 12 bits) but the 
connection to the computer might be only 1 Gbps. By using the recording and readout modes in this 
example, you can capture and stream images from the camera without losing any images (as long as there 
is space in the onboard memory).

The recording acquisition modes support back-to-back recording, which allows you to click the Stop and 
Play buttons multiple consecutive times without clearing the onboard memory.

Acquisition starts when the Play button is pressed (the AcquisitionStart command is executed) when one 
of the recording modes is selected.

Images can be stored in the CL-GigE’s onboard memory as long as there is space or until there are 512 
images in memory. For information about calculating how many images you can store, see “Calculating 
How Many Images Can be Stored in Onboard Memory” on page 66.

ContinuousRecording Mode

With this mode, images are acquired continuously and are stored in the CL-GigE’s onboard memory until 
the memory is full (or 512 images are stored in onboard memory). When this limit is reached, the 
CL-GigE stops acquiring new images from the camera. 

We recommend that you observe AcquisitionControl > BlockBufferCount (Expert or Guru visibility 
level is required). When the value for this feature stops increasing, the memory is full. For information 
about the actions that clear the images from onboard memory, see “Understanding When Images are 
Removed from the Onboard Memory” on page 66. 

To determine how many images can be stored in memory, see “Calculating How Many Images Can be 
Stored in Onboard Memory” on page 66.
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ContinuousReadout Mode

With this mode, images are continuously read (and removed) from the CL-GigE’s onboard memory. The 
readout begins at the first image in memory. To see the number of images stored in onboard memory, see 
AcquisitionControl > BlockBufferCount in the Device Control dialog box (Expert or Guru visibility 
level is required). 

Readout continues until the Stop button is pressed (AcquisitionStop command is executed) or until the 
last image has been sent by the device (BlockBufferCount will be 0).

MultiFrameRecording Mode

With this mode, a fixed number of images are stored in the CL-GigE’s onboard memory. To configure 
the number of images, set the AcquisitionControl > AcquisitionFrameCount feature in the Device 
Control dialog box. Images can be read out from memory using ContinuousReadout mode.

If AcquisitionControl > AcquisitionFrameCount is set to a value that exceeds the amount of available 
memory, the CL-GigE stops acquiring new images when the onboard memory is full (or 512 images are 
stored in onboard memory).

BlockBufferCount shows the number of images currently in memory. In MultiFrameRecording mode, 
this number is cumulative: If the memory is empty and you acquire an image, BlockBufferCount will 
match the AcquisitionFrameCount. If you stop and restart recording, BlockBufferCount will increment 
(to a maximum of 512 images, depending on the image size) and will no longer match the 
AcquisitionFrameCount.

For information about the actions that clear the images from onboard memory, see “ContinuousReadout 
Mode” on page 65.

SingleFrameRecording Mode

With this mode, a single image is saved in the CL-GigE’s onboard memory after each AcquisitionStart 
command.

For information about the actions that clear the images from onboard memory, see “Understanding 
When Images are Removed from the Onboard Memory” on page 66.

SingleFrameReadout Mode

With this mode, a single image is acquired from the CL-GigE’s onboard memory.

A maximum of 512 images can be acquired at one time in MultiFrameRecording mode.

To determine how many images can be stored in memory, see “Calculating How Many Images Can be 
Stored in Onboard Memory” on page 66.
65Connecting to the CL-GigE and Configuring General Settings Using eBUS Player



Understanding When Images are Removed from the Onboard Memory

The following actions remove the images from the CL-GigE’s onboard memory:

• Streaming images from the onboard memory using one of the readout acquisition modes 
(ContinuousReadout or SingleFrameReadout).

• Power cycling the CL-GigE, which clears all images from the onboard memory.

• Making any of the following AcquisitionMode changes and then clicking the Play button 
(AcquisitionStart command):

Calculating How Many Images Can be Stored in Onboard Memory

First, take note of the PayloadSize, which appears under TransportLayerControl in the Device Control 
dialog box. Expert or Guru visibility level is required to access this feature.

The PayloadSize is automatically calculated by the CL-GigE based on the selected image settings, which 
include Width, Height, OffsetX, OffsetY, PixelSize, any chunk data, as well as any padding that has to be 
added to the image payload.

For example, for a CL-GigE configured to use Mono10p with images that are 1920 x 1080, the 
PayloadSize is equal to 2 592 000 bytes per image or 2.472 MB (2 592 000 / 1 048 576).

You can use the following equation to determine the number of images that can be saved in onboard 
memory:

Available onboard memory MB / PayloadSize MB = Number of images that can be saved

Using our example, the equation is:

120 MB / 2.472 MB = 48 images

Implementing the eBUS SDK

You can create your own image acquisition software for the CL-GigE. Consult the following guides for 
information about creating custom image acquisition software:

• eBUS SDK API Quick Start Guides, available for C++, .NET, Linux, and macOS, which are available 
on the Pleora Support Center at supportcenter.pleora.com.

• eBUS SDK API Help Files, which are installed on your computer during the installation of the eBUS 
SDK. You can access this documentation from the Windows Start menu under eBUS SDK.

Table 23: Changes that Clear Images from the Onboard Memory

First you acquire images with... And then you change the Acquisition mode to...

ContinuousRecording, MultiFrameRecording, or 
SingleFrameRecording

Continuous, MultiFrame, or SingleFrame

SingleFrameReadout or ContinuousReadout SingleFrame, MultiFrame, or Continuous

SingleFrameReadout or ContinuousReadout ContinuousRecording, MultiFrameRecording, or 
SingleFrameRecording
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Chapter 10

Saving eBUS Player and CL-GigE Settings
This chapter describes the various ways to save your eBUS Player and CL-GigE settings.

The following topics are covered in this chapter:

• “Choosing the Best Method for Saving eBUS Player and CL-GigE Settings” on page 68

• “Using File > Save” on page 70

• “Using Tools > Save Preferences” on page 70

• “Using User Sets: Saving Settings to the CL-GigE’s Flash Memory” on page 71

• “Ensuring Configuration Settings are not Overwritten” on page 72

• “Saving the CL-GigE XML File to your Computer” on page 72

The changes that you make to your CL-GigE are temporary and WILL NOT PERSIST ACROSS POWER CYCLES 
unless you save the changes to the flash memory of the CL-GigE or to a .pvcfg file on your computer.
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Choosing the Best Method for Saving eBUS Player and 
CL-GigE Settings

eBUS Player offers several ways to save your eBUS Player and CL-GigE settings. Each method saves different settings, as 
outlined in the following table. 

Table 24: eBUS Player and CL-GigE Settings Saving Options

Format and location of saved settings:

Saves to a .pvcfg file on 
your computer

Saves to your 
computer’s user profile

Saves to the CL-GigE 
flash memory

eBUS Player procedure for saving:

File > Save
Tools > Save 
preferences

Device Control > 
Usersets

Settings saved:

Default GigE Vision host-side communication 
parameters.

These parameters are set using the Default 
GigE Vision Communication Parameters 
dialog box, accessed from the Tools menu in 
eBUS Player. 

Yes Yes No

GigE Vision host-side communication 
parameters.

These parameters are set using the 
Communication Control dialog box (click the 
Communication control button on the main 
page of eBUS Player).

Yes No No

CL-GigE parameters.

These parameters are set using the Device 
Control dialog box (click the Device control 
button on the main page of eBUS Player).

Yes No Yes

Image stream parameters.

These parameters are set using the Image 
Stream Control dialog box (click the Image 
stream control button on the main page of 
eBUS Player).

Yes No No
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1. eBUS Player settings accessed from the 
Tools menu:

• Setup: eBUS Player role and stream 
destination

• Image filtering

• Image saving

• Event monitor

• Buffer options

• Display options

2. GenICam browser settings configured using 
the Device Control dialog box: Parameter 
visibility level, browser options, expanded or 
collapsed feature lists.

Yes Yes No

Serial communication bridge settings.

These parameters are set using the Serial 
Communications Bridge dialog box, accessed 
from the Tools menu.

Yes No No

Camera bridge configuration settings. Yes Yes No

Identification (MAC address) of devices to 
which you are connected.

Yes No No

CL-GigE serial communication settings.

These parameters are set using the Device 
Serial Communication dialog box accessed 
from the Tools menu.

No No No

For more information about the settings and parameters shown in the table above, see the eBUS Player For Windows and 
Linux User Guide.

Table 24: eBUS Player and CL-GigE Settings Saving Options (Continued)

Format and location of saved settings:

Saves to a .pvcfg file on 
your computer

Saves to your 
computer’s user profile

Saves to the CL-GigE 
flash memory

eBUS Player procedure for saving:

File > Save
Tools > Save 
preferences

Device Control > 
Usersets

Settings saved:
69Saving eBUS Player and CL-GigE Settings



Using File > Save

When you select Save As on the eBUS Player File menu, the changes you have made to the eBUS Player 
application settings, along with most of the settings configured on the CL-GigE to which eBUS Player is 
connected, are saved to a .pvcfg file on your computer. When you are next connected to the CL-GigE 
using eBUS Player, you can apply the saved .pvcfg file to restore all of your previously configured settings.

The settings saved to the .pvcfg file include the MAC address for the NIC in the computer on which 
eBUS Player is installed and the MAC address of the connected CL-GigE. This enables you to connect 
to the device automatically and restore the CL-GigE and eBUS Player application settings. For more 
information about the eBUS Player settings saved using this method, see “eBUS Player and CL-GigE 
Settings Saving Options” on page 68.

To save CL-GigE settings to a .pvcfg file on your computer

1. After you have changed settings on the CL-GigE using eBUS Player, click File > Save As.

2. Choose a file name and location on your computer to save the .pvcfg file.

3. Click Save.

To apply a saved .pvcfg file to the CL-GigE

1. Connect to the CL-GigE using eBUS Player.

2. Click File > Open.

3. Navigate to the saved .pvcfg file and click Open.

Using Tools > Save Preferences

When you select Save Preferences on the eBUS Player Tools menu, specific eBUS Player application 
settings along with Communication control options, such as a specific heartbeat interval and answer 
timeout value, are saved to your Windows/Linux/macOS operating system user profile. When you next 
open eBUS Player, your preferences are the same as when you closed the application. For more 
information about the eBUS Player settings saved using this method, see “eBUS Player and CL-GigE 
Settings Saving Options” on page 68.

You can apply the settings in the saved .pvcfg file to a CL-GigE with a different MAC address.

The Device control settings and the Image stream control settings are not saved when you click Save 
Preferences.
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To save eBUS Player preferences

• Click Tools > Save Preferences.

The eBUS Player preferences, including the Communication control options such as a specific 
heartbeat interval and answer timeout value, are saved.

To restore default eBUS Player settings

• Click Tools > Restore Default Preferences.

Settings are restored to the values set on the CL-GigE before it was first used.

Using User Sets: Saving Settings to the CL-GigE’s Flash 
Memory

When you use the UserSetSave feature available in the UserSetControl section of the eBUS Player Device 
Control dialog box, you are saving configuration changes to the flash memory of the CL-GigE. These 
settings persist across power cycles. A User Set can be configured to be the default settings for the CL-
GigE so that each time you start the CL-GigE it starts with these settings applied, or you can start the 
CL-GigE and then apply User Set configurations.

Most Pleora external frame grabbers support two User Sets: UserSet1, which consists of the user-
configured settings, and Default, which consists of the pre-configured settings, to which you can always 
revert. Settings identified as Default in the Device Control dialog box cannot be changed.

The following table describes the options available in UserSetControl.

Not all CL-GigE configuration changes can be saved to a User Set. Features in the Device Control dialog 
box that can be saved to the CL-GigE’s flash memory have Streamable: True in the Help section at the 
bottom of the Device Control dialog box.

Table 25: Saving Configuration Settings to the CL-GigE

Setting Description

UserSetSelector Selects the User Set to load or save.

UserSetLoad Loads the User Set (specified by UserSetSelector) to the CL-GigE and makes it active.

UserSetSave Saves configuration data to the User Set specified by UserSetSelector, which is part of 
the non-volatile memory of the CL-GigE.

UserSetDefaultSelector Specifies the User Set to load and make active when the CL-GigE is reset or power-
cycled.

UserSetLoadLastUserSet Shows the last User Set executed by the CL-GigE from a UserSetLoad command, or as 
a result of a reset (or power cycle) of the CL-GigE.

UserSetLoadStatus Indicates the success or failure of the last User Set applied. The User Set can be 
applied through a power cycle or through user selection.
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To save a configuration change to UserSet1

1. In the Device Control dialog box, make the required configuration changes.

2. Scroll to the UserSetControl section and change the UserSetSelector setting to UserSet1.

3. Click UserSetSave.

To load the default configuration settings (one-time)

1. In the UserSetControl section of the Device Control dialog box, select Default in the 
UserSetSelector box.

2. Click the UserSetLoad setting and then click the UserSetLoad button that appears to the right.

The default settings are applied to the CL-GigE.

To specify the persistent settings that are loaded every time the CL-GigE is reset

• In the UserSetControl section of the Device Control dialog box, select a User Set in the 
UserSetDefaultSelector box and then close the Device Control dialog box.

The next time the CL-GigE is reset or power cycled, the User Set that you selected is loaded.

Ensuring Configuration Settings are not Overwritten

When you choose a method to save eBUS Player and CL-GigE settings, you could overwrite previously 
configured settings. You should consider the following when saving settings.

• Each newly applied .pvcfg file overwrites all settings configured by a previously applied .pvcfg file.

• Each newly applied .pvcfg file overwrites the settings from a previously applied User Set.

• When you apply CL-GigE settings from a User Set, device settings configured by a previously 
applied .pvcfg are overwritten.

Saving the CL-GigE XML File to your Computer

You can save the CL-GigE XML file to your computer. 

To save your camera’s XML file

1. Click Tools > Save GenICam XML.

2. Navigate to the location in which you want to save the XML file.

3. Click Save.

This allows you to view the CL-GigE’s GenICam XML file; it does not save your eBUS Player or camera 
settings.
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Chapter 11

Network Configurations for the CL-GigE
After you have connected to the CL-GigE and provided it with a unique IP address on your network, you 
can configure the CL-GigE for either unicast or multicast.

The following topics are covered in this chapter:

• “Unicast Network Configuration” on page 74

• “Multicast Network Configuration” on page 76
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Unicast Network Configuration

In the following unicast configuration, a Camera Link camera is connected to a CL-GigE and then a GigE 
switch that sends a stream of images over Ethernet to the computer. Alternatively, the CL-GigE can be 
connected directly to the computer.

The computer is configured as both a data receiver and controller, and serves as a management entity for 
the CL-GigE.

Figure 5: Unicast Network Configuration

Required Items — Unicast Network Configuration

You require the following items to set up a unicast network configuration:

• Camera Link camera

• CL-GigE and cables

• Power supply or, if using PoE, a PoE power injector or PoE-enabled GigE switch

• GigE switch (optional)

• CAT5e or CAT6 Ethernet cables

• Desktop computer or laptop with eBUS SDK installed

Management entity/
data receiver

Camera Link camera CL-GigE

GigE switch

Ethernet

Camera Link
cable
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CL-GigE Configuration — Unicast Network Configuration

After you have connected and applied power to the hardware components, use eBUS Player to configure 
the CL-GigE.

To configure the CL-GigE for a unicast network configuration

1. Start eBUS Player.

2. Click Tools > Setup.

3. Under eBUS Player Role, click Controller and data receiver.

4. Under GigE Vision Stream Destination, click Unicast, automatic.

5. Click OK.

6. Connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

7. Click Play to view a live image stream.

Example image. When the test pattern is enabled for the CL-GigE, a stream of moving lines will appear
(often black, gray, and white) instead of video from your camera.
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Multicast Network Configuration

In the following example of a multicast network configuration, the CL-GigE is connected to a GigE 
switch, and sends a stream of images over Ethernet simultaneously to both a computer and to a vDisplay 
HDI-Pro External Frame Grabber. Then, the vDisplay HDI-Pro External Frame Grabber converts it to 
an image stream for display on a monitor.

Figure 6: Multicast Network Configuration

Required Items — Multicast Network Configuration

You require the following items to set up the multicast network configuration example above:

• Camera Link camera

• CL-GigE and cables

• Power supply or, if you are using PoE, a PoE power injector or PoE-enabled GigE switch

• vDisplay HDI-Pro External Frame Grabber and corresponding power supply

• Compatible display monitor

• Cable to connect the vDisplay HDI-Pro External Frame Grabber to the display monitor

• GigE switch

• CAT5e or CAT6 Ethernet cables

• Desktop computer or laptop with eBUS SDK installed

Management entity/
data receiver GigE switch

vDisplay HDI Pro

HDMI-to-DVI
or HDMI cable

Ethernet

Ethernet

Camera Link camera
CL-GigE

Camera Link
cable
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Connecting the Hardware and Power

The following procedure explains how to connect the power, network, and data cables to the vDisplay 
HDI-Pro External Frame Grabber and CL-GigE.

To connect the network cables and apply power

1. Connect one end of a CAT5e/CAT6 cable to the Ethernet connector on your computer’s NIC. 
Attach the other end to an available port on the GigE switch.

2. Attach one end of the video cable to the display monitor. Attach the other end to the HDI 
connector on the vDisplay HDI-Pro External Frame Grabber.

3. Connect one end of a CAT5e/CAT6 cable to the vDisplay HDI-Pro External Frame Grabber 
Ethernet connector. Attach the other end to an available port on the GigE switch.

4. Connect one end of a CAT5e/CAT6 cable to the CL-GigE Ethernet connector. Attach the other 
end to an available port on the GigE switch.

5. Apply power to the devices.

The message No Video appears on the display monitor.

Configuring the Devices for a Multicast Network Configuration

After you have connected and applied power to the hardware components, use eBUS Player to configure 
the vDisplay HDI-Pro External Frame Grabber and CL-GigE for multicast configuration. You may want 
to launch two instances of eBUS Player to perform both configurations. Begin by configuring the 
vDisplay HDI-Pro External Frame Grabber. Then, configure the CL-GigE to transmit images to a 
multicast IP address and port.

No Video
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To configure the vDisplay HDI-Pro External Frame Grabber for a multicast network 
configuration

1. Start eBUS Player.

2. Click Tools > Setup.

3. Under eBUS Player Role, click Controller.

You do not need to specify the GigE Vision Stream Destination, as the stream destination is not 
applicable to a video receiver.

4. Click OK.

5. Connect to the vDisplay HDI-Pro External Frame Grabber.

For more information, see “To configure image settings on the CL-GigE” on page 56.

6. Click Device control.

7. Click Guru in the Visibility list.

8. In the TransportLayerControl > GigEVision category, set GevSCPHostPort to a streaming 
channel port (for example, 1042).

9. Set GevSCDA to a multicast address (for example, 239.192.1.1).

10.Close the Device Control dialog box.

11.Now, configure the CL-GigE, as outlined in “To configure the CL-GigE for a multicast network 
configuration” on page 79.
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To configure the CL-GigE for a multicast network configuration

1. Start an additional instance of eBUS Player.

2. Click Tools > Setup.

3. Under eBUS Player Role, click Controller and data receiver, as shown in the following image.

4. Under GigE Vision Stream Destination, click Multicast and enter the IP address and port number.

The address and port must be identical to that configured for the vDisplay HDI-Pro External Frame 
Grabber in step 8 and 9 of “To configure the vDisplay HDI-Pro External Frame Grabber for a 
multicast network configuration” on page 78.

5. Click OK.

6. Connect to the CL-GigE.

For more information, see “To start eBUS Player and connect to the CL-GigE” on page 50.

7. Under Parameters and Controls, click Device control.

8. Click Guru in the Visibility list.
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9. Under TransportLayerControl > GigEVision, ensure that the port in the GevSCPHostPort field 
and the multicast IP address in the GevSCDA field are correct. They are configured automatically 
to the values set in step 4 of this procedure.

10.Close the Device Control dialog box.
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11.Click Play to view the source image stream both on the computer and the display monitor.

Example image. When the test pattern is enabled for the CL-GigE, a stream of moving lines will appear
(often black, gray, and white) instead of video from your camera.
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Chapter 12

System Troubleshooting
This chapter provides you with troubleshooting tips and recommended solutions for issues that can occur 
during configuration, setup, and operation of the CL-GigE. It also shows you how to switch between the 
backup and main firmware loads.

Troubleshooting Tips

The scenarios and known issues listed in this chapter are those that you might encounter during the setup 
and operation of your CL-GigE. Not all possible scenarios and errors are presented. The symptoms, 
possible causes, and resolutions depend upon your particular setup and operation.

Not all scenarios and solutions are listed here. You can refer to the Pleora Technologies Support Center at 
supportcenter.pleora.com for additional support and assistance. Details for creating a customer account 
are available on the Pleora Technologies Support Center.

Refer to the product release notes that are available on the Pleora Technologies Support Center for known 
issues and other product features.

If you perform the resolution for your issue and the issue is not corrected, we recommend you review the 
other resolutions listed in this table. Some symptoms may be interrelated.
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Table 26: Troubleshooting Tips

Symptom Possible cause Resolution

SDK cannot detect or 
connect to the CL-GigE

Power not supplied to the CL-
GigE or inadequate power 
supplied

Both the detection and connection to the 
CL-GigE will fail if adequate power is not 
supplied to the device.

Re-try the connection to the device with eBUS 
Player. Verify that the Power/FPGA LED is green 
(power on). For information about the LEDs, see 
“Status LEDs” on page 26. Verify the power 
connection and ensure 5.2 V to 16 V is present 
at the connector.

Device is not connected to the 
network

Verify that the network activity LED and network 
connection speed LED are active. If these LEDs 
are illuminated, check the LEDs on your 
network switch to ensure the switch is 
functioning properly. If the problem continues, 
connect the CL-GigE directly to the computer to 
verify its operation. For information about the 
LEDs, see “Status LEDs” on page 26.

The CL-GigE and computer are 
not on the same subnet

Ensure that the CL-GigE and the computer 
running eBUS Player are on the same subnet. In 
addition, ensure that these devices are 
connected using compatible gateway and 
subnet mask information. You can view the CL-
GigE IP address information in the Available 
Devices list in eBUS Player. A red icon appears 
beside the device if there is an incompatible IP 
configuration.
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SDK is able to connect, but 
no images appear in eBUS 
Player.

In a multicast configuration, 
images appear on a display 
monitor connected to a 
vDisplay HDI-Pro External 
Frame Grabber but do not 
appear in eBUS Player.

In a multicast configuration, 
the CL-GigE may not be 
configured correctly

Images might not appear on the display if you 
have not configured the CL-GigE for a multicast 
network configuration. The CL-GigE and all 
multicast receivers (for example, a vDisplay 
HDI-Pro External Frame Grabber) must have 
identical values for both the GevSCDA and 
GevSCPHostPort features in the 
TransportLayerControl section. For more 
information, see “Multicast Network 
Configuration” on page 76.

Your computer’s firewall may 
be blocking eBUS Player

Ensure that eBUS Player is allowed to 
communicate through the firewall.

Anti-virus software blocking 
transmission

Images might not appear in eBUS Player 
because of anti-virus software on your network. 
Disable all virus scanning software and re-
attempt a connection to the CL-GigE with eBUS 
Player.

A non-Pleora GigE Vision driver 
is blocking the connection

Disable or uninstall the non-Pleora GigE Vision 
driver and install the Pleora eBUS Universal Pro 
Driver. For more information, see “Installing the 
eBUS Universal Pro Driver” on page 42.

Table 26: Troubleshooting Tips (Continued)

Symptom Possible cause Resolution
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Dropped packets: eBUS 
Player or applications created 
using the eBUS SDK

Insufficient computer 
performance

The computer being used to receive images 
from the device may not perform well enough to 
handle the data rate of the image stream. The 
GigE Vision driver reduces the amount of 
computer resources required to receive images 
and is recommended for applications that 
require high throughput. Should the application 
continue to drop packets even after the 
installation of the GigE Vision driver, a 
computer with better performance may be 
required. 

Insufficient NIC performance The NIC being used to receive images from the 
GigE Vision device may not perform well 
enough to handle the data rate of the image 
stream. For example, the bus connecting the 
NIC to the CPU may not be fast enough, or 
certain default settings on the NIC may not be 
appropriate for reception of a high-throughput 
image stream. Examples of NIC settings that 
may need to be reconfigured include the 
number of Rx Descriptors and the maximum 
size of Ethernet packets (jumbo packets). 
Additionally, some NICs are known to not work 
well in high-throughput applications.

For information about maximizing the 
performance of your system, see the 
Configuring Your Computer and Network 
Adapters for Best Performance knowledge 
base article, available on the Pleora Support 
Center. Also see “Configuring Your Computer’s 
NIC for use with the CL-GigE” on page 43.

Black bars appear on the 
sides of the images

Camera does not output 
images using the full image 
size

In eBUS Player, adjust the Width, Height, and 
image offset features until the black bars no 
longer appear.

Table 26: Troubleshooting Tips (Continued)

Symptom Possible cause Resolution
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Changing to the Backup Firmware Load

In the event that the main firmware load fails to start, the CL-GigE will start up using the backup 
firmware load when it is restarted or power cycled.

In the rare event that the backup load is not used automatically (as indicated by the fact that eBUS Player 
will not be able to detect the CL-GigE), you can use the slide switch to change to the backup load.

After the CL-GigE starts up using the backup load, you can apply a firmware update to the CL-GigE to 
recover the main load. For more information see the Updating Pleora Firmware knowledge base article on 
the Pleora Support Center (supportcenter.pleora.com).

Main load position (OFF)
Backup load position (ON)

FPGA Board (Back View)

SW1 Slide Switch
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Chapter 13

Reference: Mechanical Drawings and Material List
This chapter provides mechanical drawings and also provides a list of connectors with corresponding 
manufacturer details.

The following topics are covered in this chapter:

• “Mechanical Drawings” on page 90

• “Enclosed Model” on page 90

• “CL-GigE OEM Board Set with 12-Pin GPIO Connector” on page 92

• “CL-GigE OEM Board Set with no 12-Pin GPIO Connector” on page 95

• “GPIO Board Assembly” on page 98

• “Material List” on page 100

Three-dimensional (3-D) mechanical models are available at the Pleora Technologies Support Center.
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Mechanical Drawings

The mechanical drawings in this section provide the CL-GigE’s dimensions, features, and attributes. All 
dimensions are in millimeters. Connectors are dimensioned to the center.

Enclosed Model

Figure 7: Enclosed Model — Camera Link Connector View

Figure 8: Enclosed Model — Side View
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Figure 9: Enclosed Model — GPIO Connector View

Figure 10: Enclosed Model — Bottom View
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CL-GigE OEM Board Set with 12-Pin GPIO Connector

When you purchase the CL-GigEB-IND OEM board set (order code 900-6009), the 12-pin GPIO 
connector is not soldered to the board. If you plan on soldering the connector to the board, the following 
drawings show the dimensions with the 12-pin GPIO connector.

Figure 11: OEM Board Set with GPIO: Maximum Component Height

Figure 12: OEM Board Set with GPIO: Component Height Adapter Board
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Figure 13: OEM with GPIO: Adapter Board Detailed Measurements

Figure 14: OEM Board Set with GPIO: GigE PHY Board Detailed Measurements
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Figure 15: OEM Board Set with GPIO: Maximum Component Height
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CL-GigE OEM Board Set with no 12-Pin GPIO Connector

The drawings in this section show the CL-GigEB-IND OEM board set (order code 900-6009) without 
the 12-pin GPIO connector soldered to the board.

Figure 16: OEM Board Set No GPIO Connector: Maximum Component Height

Figure 17: OEM Board Set No GPIO Connector: Component Height Adapter Board
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Figure 18: OEM Board Set No GPIO Connector: Adapter Board Detailed Measurements

Figure 19: OEM Board Set No GPIO Connector: GigE PHY Board Detailed Measurements
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Figure 20: OEM Board Set No GPIO Connector: Maximum Component Height

42.17

1.60

1.60

1.60

48.47

NOTE: JACK SOCKETS WILL BE FASTENED TO CUSTOMER PANEL.
             PANEL THICKNESS WILL ADD TO THIS DIMENSION.

5.50

8.00

8.00

15.88

HEIGHT
COMPT

MAX
2.10

HT=2.80
97Reference: Mechanical Drawings and Material List



GPIO Board Assembly

The drawings in this section show the GPIO board assembly that is included with the CL-GigEB-IND 
Development Kit (the development kit order code is 900-6011).

Figure 21: GPIO Board — Front and Back Views

Figure 22: GPIO Board — Dimensions
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Figure 23: GPIO Board — Dimensions (Continued)

Figure 24: GPIO Board — Side Views
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Material List

The connector summaries for the CL-GigE are listed in the following table.

Table 27: Connector Summary

Description Manufacturer part number Manufacturer

RJ-45 connector RJHSE-3P85 Amphenol

12-pin circular connector HR10A-10R-12PB(71) Hirose Electric Co. Ltd.

Miniature Camera Link 12226-1100-00FR 3M

Source manufacturer, description, and identification may vary for each connector.
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Chapter 14

Appendix: Timing for Camera Link Signals
The output of the camera must match the format of the CL-GigE. You should select a case for your 
application and then refer to “Timing Values for All Cases” on page 103. The stated timing restrictions 
are minimum values.

Camera Link Signals

Case 1: FVAL and LVAL are Level-Sensitive

PB_FVAL

PB_LVAL

PB_DVAL

tFV2LV

tFV2DV

tLI2LV
tFI2FV

tFI2DV

tLV2LI

tLI2DV

PB_DATAx (1,1)
(N-1, 
M)

(0,0) (N,0)(1,0)
(N-1,

0)
(0,0) (1,0)(0,1) (N,M)

Don’t Care Window Size = N x M

tLV2DV tDI2LI

tDI2FI

tLI2FI

tFV2FI

tFV2FV

tLLI2DV
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Case 2: FVAL and LVAL are Edge-Sensitive

In this case, FVAL and LVAL are edge-sensitive.

• Start of frame/line is signaled by: A rising (or falling) edge on FVAL, which signals the start of a 
frame. A rising (or falling) edge on LVAL, which signals the start of a line.

• End of frame is signaled by: 

• The next FVAL valid edge (rising edge when rising-edge sensitive or falling edge when falling-
edge sensitive) occurs.

• Or, when all of the pixels have been acquired (as set in the image height and width settings) 
AND an end-of-frame (EOF) occurs. 
Note: EOF occurs at LVAL rising edge (when rising-edge sensitive) or LVAL falling edge (when 
falling-edge sensitive). This is an additional LVAL edge, in addition to the configured/expected 
number of lines. See the EOF indicator in the illustration below.

• Line Missing status and Partial Line Missing errors: Partial Line Missing indicates lines are ending 
early (the next LVAL valid edge occurs before all of the pixels have been acquired). Full Line Missing 
indicates that the frame is ending early (the next FVAL edge occurs before all of the lines have been 
acquired).

(1,0)
(N-1,

0)

tLI2LV

PB_FVAL

PB_LVAL

PB_DVAL

tFV2LV

tFI2FV

tLV2LI

(1,1)
(N-1, 
M)PB_DATAx] (0,0) (N,0) (0,0) (1,0)(0,1) (N,M)

Don’t Care Window Size = N x M

tFV2DV

tLV2DV

tFV2FV

tFV2FI

EoF
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Case 3: FVAL is Edge-Sensitive and LVAL is Level-Sensitive

In this case, FVAL is edge-sensitive and LVAL is level-sensitive.

• Start of frame/line is signaled by: A rising (or falling) edge on FVAL, which signals start of frame. 
The line is valid when LVAL is active (high or low depending on settings).

• End of frame is signaled by: 

• The next FVAL valid edge (rising edge when rising-edge sensitive or falling edge when falling-
edge sensitive) occurs.

• Or when all of the lines have been acquired (as set in the image height settings) AND the last 
LVAL with valid data is de-asserted (low when high level sensitive or high when low level 
sensitive). 

• Line Missing status or a Partial Line Missing error generated:

• Full Line Missing indicates that the frame is ending early (the next FVAL edge occurs before all 
of the lines have been acquired). Partial Line Missing indicates that lines are ending early (in 
this case, LVAL is de-asserted before all pixels in a line are captured).

Timing Values for All Cases

The timing values stated in the following table are minimum values only.

(1,0)
(N-1,

0)

tLI2LV

PB_FVAL

PB_LVAL

PB_DVAL

tFV2LV

tFI2FV

tLV2LI

(1,1)
(N-1, 
M)PB_DATAx (0,0) (N,0) (0,0) (1,0)(0,1) (N,M)

Don’t Care Window Size = N x M

tFV2DV

tLV2DV

tLI2DV
tDI2LI

tLLI2DV

tFV2FV

tFV2FI

Table 28: Timing Values for All Cases

From To Symbol

Case 1 
(level)

(tcp) 

Case 2 
(edge)

(tcp)

Case 3 
(both)

(tcp)

FVAL valid LVAL valid a tFV2LV 0 b 0 1

FVAL valid Data valid a, c, d tFV2DV 0 b 16 1

LVAL valid Data valid a, c, d tLV2DV 0 1 0

LVAL valid LVAL invalid a tLV2LI 1 1 1

LVAL invalid LVAL valid a tLI2LV 1 1 1
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a. The valid state of FVAL and LVAL is high when they are set as level-high sensitive or rising-edge 
sensitive. Their valid state is low when they are set as level-low sensitive or falling-edge sensitive.

b. If LVAL is valid before FVAL becomes valid, the grabber drops the full line.

c. Data valid is defined by FVAL valid (note a), LVAL valid (note a), and DVAL valid (note d).

d. The valid state of DVAL is high when it is set as level-high sensitive, and low when set as level-low 
sensitive. DVAL is always valid in the grabber when the parameter PixelBusDataValidEnabled is off.

e. If FVAL becomes invalid and LVAL is still valid, the line is truncated.

LVAL invalid

(Automatic Internal 
Retrigger disabled)

Data valid a, c, d tLI2DV 1 N/A 1

LVAL invalid

(Automatic Internal 
Re-trigger enabled)

Data valid tLI2DV 16 N/A 16

Data invalid LVAL invalid a, c, d tDI2LI 0 N/A 0

LVAL invalid FVAL invalid a tLI2FI 0 e N/A N/A

Data invalid FVAL invalid a, c, d tDI2FI 0 e N/A N/A

FVAL invalid FVAL valid a tFI2FV 1 1 1

FVAL invalid Data valid a, c, d tFI2DV 1 N/A N/A

Last LVAL invalid Data valid tLLI2DV 16 N/A 16

FVAL valid FVAL invalid tFV2FI 16 1 1

FVAL valid FVAL valid t2FV2FV 17 17 17

Table 28: Timing Values for All Cases

From To Symbol

Case 1 
(level)

(tcp) 

Case 2 
(edge)

(tcp)

Case 3 
(both)

(tcp)
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Chapter 15

Reference: Mean Time Between Failures (MTBF) Data
The following table provides MTBF data.

Assumptions:

1. The calculation is performed using the RelCalc for Windows V5.1-TELC3 software, which 
implements Telcordia SR-332 (Issue 3) failure rate models.

2. The operating internal chassis temperature is 40°C. The calculation assumes the temperature across 
the boards is relatively constant.

3. The Telcordia environment is GB.

4. Each part’s operating current/voltage/power stress is 50%.

5. The typical operating power value (as specified in the component’s datasheet) is used for each IC 
and semiconductor.

6. The calculation uses the 90% UCL (Upper Confidence Level) Telcordia Issue 3 model.

7. Each part’s Telcordia Quality Level is I.

Table 29: MTBF Data

Model MTBF @ 40°C

CL-GigE External Frame Grabber 1,014,151 hours
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Chapter 16

Technical Support
On the Pleora Support Center, you can:

• Download the latest software and firmware.

• Log a support issue.

• View documentation for current and past releases.

• Browse for solutions to problems other customers have encountered.

• Read knowledge base articles for information about common tasks.

To visit the Pleora Support Center

• Go to supportcenter.pleora.com and click Support Center.

If you have not registered yet, you are prompted to register.

Accounts are usually validated within one business day.
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